COMPUTER

WLAE-AG300N とTime Capsule

BUFFALO ネットワーク対応家電用 ワイヤレスユニット スターターパック WLAE-AG300N/V
始めは、簡単に繋がると思っていた。
製品のボックスにもそう書いてある。「簡単に接続」
それが甘い考えだと知ったのは、製品を箱から取り出して、電源を入れ、設定を開始して10分後だった。
ことの発端は、いろんなメディアの映像をNASに残したいと考えたところから。
しかし、ここで問題が。

我が家はNAS配置予定場所(テレビの付近)から、インターネットへ接続するためのLANポートまでかなり距離がある。
なので、この距離を接続するには
・有線で配線する。
・無線で接続する。
の二つしか選択肢が無い。
このうち、有線は問題外。
賃貸なので、LANケーブルの配線は部屋の中を走らざるを得ない。
何メートルもLANケーブルが部屋の中を走っているというのは、想像しただけでぞっとする。
なので、無線での接続以外は考えられない。
既に無線環境はあるので、子機を追加で購入するだけで良い。
ただ、NASを購入した上に無線の子機を購入するとなると、やや予算が厳しい。
諦めるかと、思っていた。
思っていたが….
ネットで調べると、予想以上に無線の子機が安い。
これほどに安いのであれば、購入してみても良かろうと考え直す。
これがそもそもの過ちとは思わずに、安価な無線子機 buffalo社のWLAE-AG300Nを購入してしまった。
そして最初に戻る。


ここで簡単に我が家のN/W環境を。
無線LAN親機はTime Capsule。
インターネットは光ファイバ。
光ファイバの出口ダイニングにある。
TVを設置している場所はリビング。
間に引き戸がある。
こんな環境なので、この間を無線で接続しようと考えた。
既存の無線LAN環境に無線子機のイーサネットコンバータを追加する。
つまり無線の親機はApple の TimeCapsule、子機がbuffaloのWLAE-AG300Nという構成になる。
一応、購入前にはちょろっとネットで調べている。
当然自己責任だが、上記の構成で接続できたと書かれている。
なので、安心していた。が、甘かったという訳だ。
この手の無線LAN機器を設定するのに、付属のツール (SNMPなんかで自動的に機器を探してくるかんたん~とか言う名前のやつ)とか使ったことがない私は、おもむろにMacとWLAEをLANケーブルで接続。
Mac側のIPを192.168.11.xx/24に変更して、ブラウザから http://192.168.11.100をオープン。
buffaloのルーターにデフォルトで設定されているユーザー名 rootで管理画面にログイン。
細かい設定は後回しにし、「無線設定」「エアステーション間接続」をクリック。
パラメータを以下のとおりに設定。
・エアステーション間接続機能 :使用する
・親機/子機指定 :子機(EC)
・SSID : 設定しているSSID
・無線の認証 : WPA2-PSK (親機に設定しているものと同じ認証方式)
・無線の暗号化 : AES(親機に設定しているものと同じ暗号化方式)
・WPA-PSK(事前共有キー) : XXXXXX
・優先接続先指定 : 設定なし
設定を保存後、親機と繋がったことを確認する。
管理画面の「ステータス」をクリックし状況を確認する。
状態という項目が接続状況を示す。
しかし、状態が「親機検索中」となっている。念のため、画面のリロードを行っても変化がない。
SSIDとか認証方式の設定、事前共有キーの設定間違えたかなと、全てを打ち直す。
再度、ステータスを確認するが状態が変わらない。
これ以上、設定するところも項目もない。親機にはMACアドレス認証も掛けてない。
何故?接続できない理由が解らない。
その後も、ちょろちょろとパラメータを変更してみるが、状況は変わらない。
キエエエエエッッ!とエンジェル伝説の主人公風に奇声をあげそうになるところをなんとか押さえる。
こんな時、パニックになると禄なことが無い。
twitterのタイムラインなぞ見て、気を落ち着ける。
気が落ち着いたところで情報を収集。
buffaloのサポートがアテにならないことは、過去の経験からある程度解っていたので、頼りになるのはウェブ上の経験談と自分のみ。
…………
あった。該当する情報が。
appleのdisscussionにちょろっと記載されていた。
その情報によると、この商品、親機のtime capsuleで「非公開ネットワーク」を設定していると、SSIDを手入力しても「親機検索中」となり、親機と接続できないとある。
うーん、バギー。さすがバッファロー、良い仕事してます。
早速、time capsule側の「非公開ネットワーク」を無効に。
ブラウザをリロードすると、状態が「接続中」となり繋がったことが確認できた。
…………
SSIDが晒されてしまうという気持ち悪さとがあるが、接続されたことに一安心。
SSIDが公開される変わりにMACアドレス制御を後で設定しようと、前向きに考え、とりあえず残りの項目を設定する。
あと残っている設定としては
・無線LANの無効化(子機として使用する場合は、無効にしておいて良い)
・NTPの設定
・ホスト名の変更
・子機のIPアドレスをLAN内に合わせて変更
・パスワードの設定
ざざっと設定を行い、作業完了。
最後にpingで動作に問題がないことを確認する。
正式に設置するため、電源ボタンで電源を落とす。
子機(WLAE)をTV付近のコンセントに接続し、電源をオンに。
Macから、pingでWLAEに設定したIPに通信できるかを確認。
…….ん? 
…….んん?あでえ?
いつまで経ってもpingが通らない。
なにか障害でも起きているのかと再度、MacとWLAEをLANケーブルで接続して確認。
有線にするとpingが通る。ブラウザからログインしてステータスを確認する。
ん?
ステータスが確認できない。
ステータスを確認しようとすると、WLAEから応答が無くなる。
それだけではなくpingも通らなくなる。その後は全く反応しない。
内部状況が確認できないのではっきりとは言えないが、H/Wがハングアップしているよう。
しょうがないので、電源を長押しして、再度、電源を入れ直す。
で、再度、ステータスを確認しようとすると、ステータス表示のところで同じようにハングアップしてpingも通らなくなる。
ここで状況を整理。
・再起動すると、pingも通り、管理画面へのログインは可能。
・管理画面からステータス表示になると応答が無くなる。
・この状態になると、子機を再起動するまで反応がしない。
・親機との接続は出来ていない。
ファームウェアも最新なので、初期不良?と考えつつも、念のため設定の初期化を行ってみることにする。
最初に管理画面から初期化を実行するが、全く実行されず。(実行ボタンをクリックして140秒待つようにという表示から応答が無くなる)
待っていても仕方ないので、マニュアルを見てハードリセットを行うことにする。
本体の側面にリセットボタンがあり、電源が入っている状態で2秒以上リセットボタンを押すと設定が初期化される。
早速試してみるが、全くリセットされない。
リセットボタンを押すと、LEDが消え、その後、また点灯するようなことがマニュアルには書いてあるが、電源が切れた後、まったく起動してこない。
これは完全に初期不良と判断しつつ、まだ諦めきれない。
念のため、同様の現象がないかをwebで調べてみる。
…. あった。
heibonnahibi様のサイト Macで綴る「へーぼんな日々」に
“WLAE-AG300N/Vは、Macでのトラブル頻発?”
という記事があり、そちらに同様のトラブルが発生した時のリセット方法が記載されているのを発見。
正確な方法はサイトを閲覧してもらうとして、結果として記載されている内容でH/Wのリセットができた。
リセットボタンを押すタイミングがかなりシビア。
このリセット方法を確立するまで、かなりのトライ&エラーを繰り返してきたのだろうと想像して、記事に感謝しつつ、記事の他の部分を読む。
リセット方法以外の内容は要約すると
・親機はAirmac Extreme
・電源を一度でも落とすと、次から正常に起動しなくなる。
・初期化して初回の設定時には繋がる。
・なので初回の起動時に設定を完了してそのまま使っている。
我が家のトラブルと全く同様。
記事にあったamazonのサイトを見る。
同様の現象が多々発生しているよう。
もうこれは仕様だと諦めて、やや後ろ向きな対策を考える。
どうもサイトで見る限り、この問題は他社製の親機と接続したときに発生しているよう。
もし親機との相性で発生しているのであれば、WLAEをもう一台購入し、これを親機として設定、Time Capsuleとは別の無線ネットワークを作成すれば良いのではないか。
(恐らくSSIDの件も解消されるだろうと思われる。)
親機がWLAEでも状況が変わらなければ実用に値しないので、確実に返品だが、上記で回避できるのであれば、まあいいかと考え、amazonのポイントを使って、もう一台WLAEを注文してしまった。
今のところは、とりあえず設定し直して接続が出来ている。
間違って電源を落とさない限りは大丈夫なようだ。
また、WLAEが到着したら、テストを行う。
2011/06/13 追記
amazonで注文したWLAEが到着したので、新たに購入したものを親機、既存のWLAEを子機として設定してみた。
既存のTime Capsuleとは別の無線ネットワークを作成する構成。
IPゾーンは同じなので、どちらの無線ネットワークとも接続できる。
結果から言うと問題なく接続ができた。子機のコンセントを抜いても問題は発生しない。
この記事に記載した問題は親機がTime Capsuleの時のみ発生することが解った。
※親機がTimeCapsule以外の時でも同様の問題が発生する可能性があります。ここでは検証したのがTimeCapsuleという認識です。
ちなみにSSIDに関しては仕様のようで、親機・子機ともにWLAEでもステルスにしておくと接続ができなかった。(へんな仕様)

関連記事

  1. COMPUTER

    fstabの書き換え

    Linuxを使用していて、/etc/fstabの書き換えたところ、正常…

  2. COMPUTER

    VMware Server を Debian Etchで

    先日、VMware ServerをDebian Etch (4.0)で…

  3. COMPUTER

    RHEL 5 への qmailインストール (PORT587)

    前回の続きです。すでに25番ポートで動作するqmailがインストー…

  4. COMPUTER

    RHEL 5 への qmailインストール (vpopmail)

    前回までに以下の手順を記載しました。・通常のqmail(port2…

  5. COMPUTER

    sendmailとspamassassin

    自分の中では終わったMTA sendmailしかし、何故か、今回、…

  6. COMPUTER

    debian etchでaptitude updateに失敗する

    debianもlennyがリリースされてからだいぶ経ちます。我が家…

コメント

  1. この記事へのコメントはありません。

  1. この記事へのトラックバックはありません。

  1. BOOKS

    最終目的地
  2. MMA

    ヒョードル
  3. ayame-spike

    WEAR

    ayame spike
  4. MMA

    UFC 126
  5. fuyu-no-denari

    BOOKS

    冬のデナリを読んでマッキンリーに思いを馳せる
PAGE TOP